Linux-PAM 0.99 upgrade

Hmmm, greated this morning with a pam upgrade. The einfo message looked somewhat hairy:

>> Merging sys-libs/pam-0.99.8.1-r1 to /
*
* Your current setup is using the pam_stack module.
* This module is deprecated and no more supported, and since version
* 0.99 is no more installed, nor provided by any other package.
* The package will be built (to allow binary package builds), but will
* not be installed.
* Please replace pam_stack usage with proper include directive usage,
* following the PAM Upgrade guide at the following URL
*   http://www.gentoo.org/proj/en/base/pam/upgrade-0.99.xml
*
*
* ERROR: sys-libs/pam-0.99.8.1-r1 failed.
* Call stack:
*   ebuild.sh, line 1670:   Called dyn_preinst
*   ebuild.sh, line 1107:   Called pkg_preinst
*   pam-0.99.8.1-r1.ebuild, line 162:   Called die
*
* deprecated PAM modules still used
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/var/tmp/portage/sys-libs/pam-0.99.8.1-r1/temp/build.log'.
*
!!! FAILED preinst: 1

I checked out the upgrade guide at Gentoo, and it looks pretty straight forward, I'm mostly concerned with mail services breaking with this. I'll keep you all posted on what I find out. I'm hoping that it'll be a smooth upgrade. I could really use a break from scary upgrades for a bit.. apache2, then PHP now pam?