apache-2.0.59-r5 to apache-2.2.4-r12 ... WTF?

Okay, so after the weirdness with apache-2.0.59-r5, I finally have a working apache install with my apache-tools (apache2ctl, htpasswd2, etc). The problem was the original ebuild did not include these and app-admin/apache-tools as being blocked. To get apache-tools you needed to upgrade to apache-2.2.24-r12, which I was not comfortable with.

After various bug reports (and previously mentioned here), they were able to get a working apache 2.0.59, without the need for apache-tools and everything was looking good. I saw some weird behavious with apache2ctl (needing -D flags when apache2ctl is trying to test the config), but that is something I can live with while they sort this out.

But to my disbelief, this morning, I see that apache-2.2.4-r12 is now a needed upgrade!?!?!? So this sucks, after dealing with that fiasco, I need to see if I can get 2.2.4 working now... very frustrating. I absolutely love Gentoo, but times like this is when I get slighly irritated. Time is hard to come by, and doing an upgrade like this.. you need to spend some time or you're going to experience some major breakage. I'm hoping the upgrade is somewhat easy. I do see that the httpd.conf has been redone, so that sucks.

Looks like others share my frustration. This bugs describes, in small details, and then the proposal to push the 'newer' apache as a fix to the situation with 2.0.59.